#1 2020-05-30 22:29:07

xaix1999
Member
Registered: 2019-03-08
Posts: 3

switch to mdadm /home not mounting

having an issue with the change to mdadm (happened after refind replaced refind-efi)
I thought my 2 hdd in raid 1 were failing after mdadm upgrade
they are mounted at /home
replaced hdds with ssds also upgraded / to bigger newer ssd
thought motherboard sata controller was failing
built new computer
issue persists
changed out the hdds which have msdos partition with btrfs
dd md127 to newly created md125
also dd / to new ssd
ordered disks to boot / first to start services
mdadm assembles md125 ok
issue is that /home on md125 won't mount during boot
fstab is setup for uuids from blkid to mount
but it won't mount
I have to boot into rescue from grub edit to check if it mounts everytime
which I have to mount -a and it sometimes states mount point is busy
then /home appears
I obviously can't figure this out since I built a new computer for nothing (had this install since oct2016)
I need some help please
I have tried a many different combination of fstab options with no luck
for example x-systemd.automount changes file system type to autofs and won't mount my btrfs partition
rescue works with Ctrl d and also checking if /home mounts
I've also done x-systemd.requires=localfs.target with .automount .devicetimeout=10s and others

Last edited by xaix1999 (2020-05-30 23:32:00)

Offline

#2 2020-06-03 19:47:59

xaix1999
Member
Registered: 2019-03-08
Posts: 3

Re: switch to mdadm /home not mounting

probably just a problem in an update
problem has fixed it's self

Offline

Board footer