#1 2018-11-26 05:53:21

Registered: 2018-11-26
Posts: 1

cups / hplip not working

Heyyo, so I installed bbqlinux-2018.10.14-x86_64-cinnamon and did all the package updates and cups doesn't work for me... cups homepage loads http://localhost:631/ but as soon as I click on anything like jobs or any other links? "Internal Server Error"

I then tried "sudo pacman -S hplip" and then "hp-setup" and that also fails to add the printer. I can get to the ppd selection and then manually pick my HP Officejet 4650... but then it crashes and fails to add my printer.

I'm unsure if hplip uses cups but I think it does... so is there something that I need to do to fix cups? I tried using "sudo pacman -Rs cups" and then "sudo pacman -S cups" and still the "Internal Server Error" error.


I also tried...

sudo systemctl enable org.cups.cupsd.service
sudo systemctl daemon-reload
sudo systemctl start org.cups.cupsd.service

Still can't use cups. Internal Server Error...

Last edited by ThE_MarD (2018-11-26 06:07:19)


#2 2018-12-01 11:33:56

Registered: 2014-10-05
Posts: 106

Re: cups / hplip not working

Works fine here. Just added a Kyocera ECOSYS M5521cdn.

# Add your user to the lpadmin group
gpasswd --add username lpadmin

# Enable and start cups service
sudo systemctl enable org.cups.cupsd.service
sudo systemctl start org.cups.cupsd.service

# Browse to

Manage -> Add Printer -> Enter username and password -> ...


Board footer