#1 2014-10-05 08:18:39

codeworkx
Administrator
Registered: 2014-10-05
Posts: 86

[FIX] invalid or corrupted package (PGP signature)

If you've installed bbqlinux using one of our ISOs and getting errors like:

error: jre6-compat: signature from "Daniel Hillenbrand <codeworkx@bbqlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/jre6-compat-2:6u51-09-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature))

run the following few commands to fix this:

sudo rm -f /etc/systemd/system/etc-pacman.d-gnupg.mount
sudo rm -f /etc/systemd/system/pacman-init.service
sudo reboot
sudo rm -rf /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux
sudo pacman-key --populate bbqlinux

Offline

Board footer